Upgrade ReleaseKit and require Go 1.26
This commit is contained in:
@@ -7,9 +7,11 @@ caller retains process startup, signal handling, and exit mapping.
|
||||
|
||||
## Go compatibility
|
||||
|
||||
The consumer minimum is declared in [go.mod](../../go.mod). Its current patch
|
||||
minimum follows the pinned PromptKit v0.12.0 dependency's `go 1.25.5` requirement;
|
||||
see that dependency's [module declaration](https://gitea.maximumdirect.net/eric/promptkit/src/commit/4b8169da286917fde7875425bb32b799b12c6af3/go.mod).
|
||||
The consumer minimum is declared in [go.mod](../../go.mod): Go 1.26.0.
|
||||
ReleaseKit v0.3.0 requires that version and is selected as a tool dependency in
|
||||
the same module graph. The minimum therefore applies to library consumers even
|
||||
though production packages do not import ReleaseKit. Consumers using Go 1.25
|
||||
need a Go 1.26 or newer toolchain to adopt this revision.
|
||||
|
||||
The [release policy](../policy/release.md#consumer-minimum-and-release-toolchain)
|
||||
defines support assumptions and versioning for changes to that minimum.
|
||||
|
||||
Reference in New Issue
Block a user